Mac fullscreen without doc and menubar popping up

  • Mac fullscreen without doc and menubar popping up

    I post this in hope for any DEV to se this and include this as the standard code for the mac fullscreen option.
    So that mac users can play without menubar and doc popping up when things we want to click are neat the top or bottom of the screen.
    This does not alter the game in any way that could be called cheating. Actually just puts us mac users on par with the pc users (no more menubar popup when trying to click that red player at the top/bottom of your screen).

    The problem: When your mouse gets to close to top or bottom of the screen the menubar or the doc will pop up over your game.
    But if u change the code in the games main application to include:
    It removes and keeps both locked out.
    The number 3 in <integer>3</integer> indicates that you want both menubar and doc not to show and not pop up.
    This can be changed to make the fullscreen behave differently from 0-4.
    0- Always show both menu bar and doc.
    1- Show menubar hide doc. Reveals when mouse gets near.
    2- Show menubar hide doc. Does not reveal it when mouse is near.
    3- Hide menubar hide doc. Does not reveal either when mouse near.
    4- Hide menubar hide doc. Reveals both when mouse gets near (Current function for albion online app).

    I have attached a screenshot of the code highlighting the location where it should be inserted to function properly.
    The code should be placed in alphabetical order to avoid possible errors.

    Please note this is the game app code and not the launchers code.
    If you start the game via the launcher it will rewrite the code to its original form.
    Any update will reset the code.
    So to play with true fullscreen you will need to launch the game from the game application and not the launcher.
    That is until or if the developers change this.

    WARNING! I assume the main reason this is not an available option on mac is if the application in fullscreen mode is non responsive you can always access the menubar to force close the application (If u don't know the command: cmd+alt+esc).
    • Screen Shot 2018-01-30 at 18.42.23.png

      271.46 kB, 1,514×1,262, viewed 508 times