Pinned Black Screen & Cant Login Thread

    • Hi. New to the game. I don't know if this has been asked before so I apologize if I ask this again. Been at it for 3 hours fixing this and looking at threads about it but I can't seem to find a solution for my problem.

      Launcher does not start the game. Only shows a black/white screen with the sound. Tried different resolutions and modes (windowed, full screen, borderless) and disabled the intro video but it does not work. However, starting the game from the game file itself, it works fine. I can login and play for a few seconds because obviously, Easy Anti Cheat logs me out because I didn't use the launcher.

      Hope someone could help. Cheers!
    • Jeebus08 wrote:

      Hi. New to the game. I don't know if this has been asked before so I apologize if I ask this again. Been at it for 3 hours fixing this and looking at threads about it but I can't seem to find a solution for my problem.

      Launcher does not start the game. Only shows a black/white screen with the sound. Tried different resolutions and modes (windowed, full screen, borderless) and disabled the intro video but it does not work. However, starting the game from the game file itself, it works fine. I can login and play for a few seconds because obviously, Easy Anti Cheat logs me out because I didn't use the launcher.

      Hope someone could help. Cheers!

      Hi, just checking that you already tried repairing the client and/or reinstalling the game?

      Mytherceria#3744
    • Mytherceria wrote:

      Jeebus08 wrote:

      Hi. New to the game. I don't know if this has been asked before so I apologize if I ask this again. Been at it for 3 hours fixing this and looking at threads about it but I can't seem to find a solution for my problem.

      Launcher does not start the game. Only shows a black/white screen with the sound. Tried different resolutions and modes (windowed, full screen, borderless) and disabled the intro video but it does not work. However, starting the game from the game file itself, it works fine. I can login and play for a few seconds because obviously, Easy Anti Cheat logs me out because I didn't use the launcher.

      Hope someone could help. Cheers!
      Hi, just checking that you already tried repairing the client and/or reinstalling the game?
      Yep. Tried reinstalling it 3 times but still no good. Tried repairing the client too. Thanks for your response.
    • Jeebus08 wrote:

      Yep. Tried reinstalling it 3 times but still no good. Tried repairing the client too. Thanks for your response.

      In this case, could you please DM me here or on Discord at Mytherceria#3744 your IGN, country, operating system, ISP, IPv4 address, as well as the results via screenshot of: entering "tracert loginserver.live.albion.zone" in the command prompt console, so that I can get this checked out by the devs.

      Just for reference, you can use whatismyipaddress.com/ to find out your IP address.

      Mytherceria#3744