Launcher won't popup

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Launcher won't popup

    Hi all,

    I have an issue with the launcher that won't start after the installation.
    I am running it on gaming laptop with w10.

    On my desktop computer (also with w10) it works all fine.
    The game client start fine, but won't connect of course due to an old version that must be updated first by the launcher.

    What happens
    I start albion launcher and it appears in my tray minimized.
    It wont pop up or do anything.
    Memory and performance looks normal.

    What I tried
    - I reinstalled the game fresh (i.e. downloaded again)
    - I checked all windows updates and graphical card updates and all is fine
    - I tried to run the launcher in admin mode and compatibility of various system


    Any ideas how to fix this?
    Optionally a link to the latest version would also be fine if I did not need to update it.

    The post was edited 1 time, last by baxik ().