[Tuto][Linux] Have a working game !

    • Veikko wrote:

      Update broke the game for me as well. I'm using Fedora 27. Here's how I fixed it:

      1) Remove your game files and download and install it again with albiononline.com/en/download (to save launcher update time, you can keep old game_x64 folder and put it to new game folder)
      2) Don't use the script provided in this thread. Instead just use the following command in terminal:

      Source Code

      1. LD_PRELOAD=~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0 ~/albiononline/launcher/Albion-Online
      That worked for me... I'm using Debian 9. Thank you. :)
      Solo for now.
    • HuHaHu wrote:

      Here it worked too on Debian testing, thank you

      Only differnce the path to steam lib

      Source Code

      1. LD_PRELOAD=~/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0 ~/albiononline/Albion-Online
      I have been doing this for a year without problem on Debian 8 xfce. Don't search too far. I would add that those message
      "Unable to preload the following plugins:
      libSDL2-2.0.so.0
      Player data archive not found at `/home/odintree/albiononline/game_x64/Albion-Online_Data/data.unity3d`, using local filesystem"
      should be non-blocking, I always get those messages and game is working perfectly.

      EDIT: Just tried starting Albion without the LD_PRELOAD for the first time in a year and it's working now directly for me, guess they fixed things. Weird that my old system is getting improved compatibility with time :)

      The post was edited 1 time, last by Ribz ().

    • GUYS! GOOD NEWS!
      A guy in Steam found the game bugs.
      steamcommunity.com/app/761890/…ns/0/1693795812290188363/


      Here it is the problem and fix:


      Originally posted by Alfa-Omega:
      I am going to explain what is wrong with this game, and why is not working on several Linux distros, maybe this helps somebody and even the developers to fix this issue.


      First of all sorry for my bad english, is not my native language and I do a lot of mistakes when I write large texts like this one.



      Ok, let me try to explain why this game fails for a lot of people and why works for others.


      The main problem is related with the libSDL2-2.0.so.0 library packed inside the game, this file is located here (inside the instalation folder):


      Albion Online/game_x64/Albion-Online_Data/Plugins/x86_64/

      Ok, this version of SDL is a wrong version, no matter in what distro you are running the game, the version packed has some missing functions that the game needs.


      So... how it's possible that the game works in some distros?? when the game loads this version of SDL and it sees that has some missing functions the game try to load the system version of the SDL (normally located at /usr/lib64), and some Linux distributions, like Ubuntu 16, has the correct version, so the game works (or maybe not, because of the libsdnio library).


      but wait, because the problem is even deeper, the SDL version packed inside the game has a dependency of the libsndio library, so if you don't have that library instaled in your system the game is going to crash, because the SDL version packed inside the game cannot meet this dependency, so, even if this SDL version is not used by the game because have missing functions it makes the game crash because cannot meet some of its dependencies.


      So, to summarize, the game only works if your system meets this requirements:


      -You have the libsndio library installed in your system


      -You have the right version of SDL installed in your system



      the only mission of the libsndio file is to make the game not crash because of the SDL library packed inside the game (none of the functions inside this library is used)



      Here you can be in two situations:


      1º- you DON't have the libsndio library: the game is going to crash after the albion launcher


      2º- you have the the libsndio library but not the right SDL version: the game is going to get stuck at 1%



      (in some distros the libsndio library is a little bit weird, in my distro, openSUSE, this library does not exist, at least I couldn't find it..)


      One workaround to all of this (is the one I post before in the thread) is just to delete the SDL version packed inside the game and load the right version (Steam should load the correct version when you launch the game from steam), anyway here we got another problem and is that the albion launcher check all the files installed and if one is missing the launcher is going to download the file missing, so my workaround bypass the albion launcher to prevent that the launcher redownload again the bad SDL version.



      ----- HERE COMES THE FIX -----

      (this fix allow you to use the Albion launcher)


      Just two steps:


      1- Get the libsndio library


      2- Update the albion script to force the use of the steam SDL version




      Explanation:


      1- First download the "libsndio.so.6.1" file from here: https://nofile.io/f/hEMNfgyAQ09


      You have to place this file inside /usr/lib64, you can do it like this from the folder where you got the libsndio.so.6.1 file (you need root permissions):


      #cp libsndio.so.6.1 /usr/lib64/libsndio.so.6.1


      2- Open the Albion folder, the location inside steam should be this:


      ~/.local/share/Steam/SteamApps/common/Albion\ Online/

      But anyway you can open the folder through steam: Right click on albion game -> Properties -> Local Files -> Browse local files


      once inside the albion folder, should be a script inside named "Albion-Online" open it with a text editor


      you have to modify the last line of the script like this to force the use of the SDL version of steam:


      LD_PRELOAD=~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0 "$SCRIPTPATH/launcher/Albion-Online" "--no-sandbox" "$@" &


      So the content of the whole script must be like this:


      #!/bin/shSCRIPT=$(readlink -f "$0")SCRIPTPATH=$(dirname "$SCRIPT")export QT_QPA_PLATFORM_PLUGIN_PATH="$SCRIPTPATH/launcher/plugins/platforms"export QT_PLUGIN_PATH="$SCRIPTPATH/launcher/plugins/"LD_PRELOAD=~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0 "$SCRIPTPATH/launcher/Albion-Online" "--no-sandbox" "$@" &


      Now save the file and launch the game from steam, the game should work fine now


      NOTE: using this method makes the steam overlay doesn't work (at lesat for me), so I prefer to use the method I post before bypassing the albion launcher.


      I think that's everything, I you have any question I'll try to answer you
    • Trying this on Archlinux using the 340 Nvidia driver and it doesn't work.

      I get the following:

      Source Code

      1. ./runab.sh
      2. sed: can't read /home/me/.config/unity3d/Sandbox Interactive GmbH/Albion Online Client/prefs: No such file or directory
      3. sed: can't read /home/me/.config/unity3d/Sandbox Interactive GmbH/Albion Online Client/prefs: No such file or directory
      4. libGL error: No matching fbConfigs or visuals found
      5. libGL error: failed to load driver: swrast
      6. Could not initialize GLX
      7. ./runab.sh: line 22: 31722 Aborted (core dumped) LD_PRELOAD=~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0 "$SCRIPTPATH/launcher/Albion-Online"


      Steam and all the other prereqs are installed and both Steam and other games work fine. Glxgears works fine as well.

      If I do the following then the launcher works, but I then get the 1% error:

      Source Code

      1. sudo ln -s /usr/lib/libsndio.so.7.0 /usr/lib/libsndio.so.6.1

      The post was edited 1 time, last by TwistedSid ().

    • Havent been playing Albion Online since beta, wanted to check the game out again.
      Seems like there are still the same issues with Linux .. sad to see :(

      Getting the following error when trying to launch the game:


      arch/mnt/storage/albiononline(:|✔) % LD_PRELOAD=~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0 /mnt/storage/albiononline/launcher/Albion-Online
      libpng warning: iCCP: known incorrect sRGB profile
      [0721/115200.115531:WARNING:stack_trace_posix.cc(699)] Failed to open file: /tmp/.glkSUPbf (deleted)
      Error: No such file or directory
      [6234:6234:0721/115200.184526:ERROR:gpu_process_transport_factory.cc(1019)] Lost UI shared context.
      arch/mnt/storage/albiononline(:|✔) % Found path: /mnt/storage/albiononline/game_x64/Albion-Online
      Mono path[0] = '/mnt/storage/albiononline/game_x64/Albion-Online_Data/Managed'
      Mono path[1] = '/mnt/storage/albiononline/game_x64/Albion-Online_Data/Mono'
      Mono config path = '/mnt/storage/albiononline/game_x64/Albion-Online_Data/Mono/etc'
      Preloaded 'ScreenSelector.so'
      Preloaded 'libAkSoundEngine.so'
      Unable to preload the following plugins:
      libSDL2-2.0.so.0
      Player data archive not found at `/mnt/storage/albiononline/game_x64/Albion-Online_Data/data.unity3d`, using local filesystem

      The file ~/.local/share/Steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libSDL2-2.0.so.0 exists tho.

      Got my version from live.albiononline.com/clients/albion-online-fullgame-linux.zip
      Linux void 4.10.17_1 x86_64 GNU/Linux
    • Client was working fine some time around 17 jul 2018.

      Then, after some update, launcher starts with a message box

      ========================================
      INFO

      For working Audio in Albion Online SDL2 is required,
      please install it with 'sudo apt-get install libsdl2-2.0-0'
      ========================================

      while Libsdl2 is installed already

      ========================================
      sudo apt-get install libsdl2-2.0-0
      [sudo] password for :
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      libsdl2-2.0-0 is already the newest version (2.0.8+dfsg1-1).

      0 upgraded, 0 newly installed, 0 to remove and 130 not upgraded.
      ========================================

      If you press "PLAY" on launcher, it will go to game loading splash screen (with fisheman), and hang dead on 1%

      Removing and redownloading/reinstalling albion online client and libsdl2-2 does not help.

      uname -a
      Linux myhost 4.13.0-45-generic #50~16.04.1-Ubuntu SMP Wed May 30 11:18:27 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
    • Did all that, I have Steam installed, I did

      locate libSDL2-2.0.so.0

      found one that is 64 bit version used by Steam
      inserted its path in launcher script
      added the game in Steam AND

      --- drum roll ---

      still got that ugly message box that "you need to apt-get install libSDL bla bla"

      Of course, game still hangs at 1%

      Launch from terminal with LD_PRELOAD= + game launcher gives the same results
      Errors in terminal are

      $ LD_PRELOAD=~/.steam/ubuntu12_64/libSDL2-2.0.so.0 ~/games/ao/Albion-Online
      $ libpng warning: iCCP: known incorrect sRGB profile
      [0724/225103.555986:WARNING:stack_trace_posix.cc(699)] Failed to open file: /tmp/.gl5WUQCQ (deleted)
      Error: No such file or directory
      [24463:24463:0724/225103.672033:ERROR:gpu_process_transport_factory.cc(1019)] Lost UI shared context.

      (launcher shows message box with "install libSDL2-2")
    • you don't have other steam libSDL?

      why .steam/ubuntu12_64/libSDL2-2.0.so.0 ?

      My install have like 4 differents libSDL2. No ubuntu12_32 folder?

      The versionning of a library will tell you about the code but not how its compiled, many things can make a difference on how the binary will be, like the target architecture, the linking to others libraries or the used compiler.

      The post was edited 1 time, last by Ribz ().

    • I use flatpak in Fedora 29 to install and run the game.


      Setup flatpak: flatpak.org/setup/

      After setting up flatpak:

      Shell-Script

      1. flatpak install flathub com.albiononline.AlbionOnline


      Then run Albion:

      Source Code

      1. flatpak run com.albiononline.AlbionOnline


      Between Graphics Drivers updates or Client updates, running the following should get you back in action:

      Source Code

      1. flatpak update

      Hope this helps people, if you have any questions, feel free to PM me.
    • Hi everyone, I'm on Manjaro os and i try to play albion. Unfortunately the game just don't launch and I tried the solution gave here but it doesn't work at all can someone please help me ? :huh:

      PS : This is the error returned by the bash files in terminal :

      ls: impossible d'accéder à 'launcher/': Aucun fichier ou dossier de ce type
      launcher.sh: ligne 21: ./julien/Documents/My Games/launcher/Albion-Online: Aucun fichier ou dossier de ce type
      ;( ;(
    • Hi!, Thanks to the work of getting this working.
      I have a new Arch linux installation with X11 DM, and after all the steps I wasn't getting to work.

      But after install XFCE and started it for the first time the game works, now if i use only X11 I can play it.

      I'm writing this reply to give some record, and maybe can help someone.

      Cheers.