300 FPS drops to 10-20 FPS

  • 300 FPS drops to 10-20 FPS

    I've just installed the game, all my drivers are up to date. I'm running:
    i5 4670k
    16gb ramm
    r9 290 4gb

    I'm only roaming round the beginner areas, without really anyone by me so it's not like there is a massive population to cause any strain. I go from 250-300 FPS down to 10-20FPS for a few seconds which causes a lot of stuttering then back up to normal. I've tried V-Sync but that hasn't helped, it's doing this about every minute.

    Any ideas?
  • Ryzen 1700x
    16gb ram ddr4
    gtx 980

    Been getting the same thing since the latest update, normally I'm sitting smug at 200 fps (my cap) and only drops when I'm in a HUGELY populated area, down to around 20-50 FPS. Now I'll drop from 200, to around 60 when I'm walking around a zone with no one near me apart from mobs.
    Tired of LAGGING in-game? Try ExitLag;
    Use my link & code 'ROBIN' for 20% off any plan!
    exitl.ag/robin
    youtube.com/c/robinhoodrs
  • Robinhoodrs wrote:

    Ryzen 1700x
    16gb ram ddr4
    gtx 980

    Been getting the same thing since the latest update, normally I'm sitting smug at 200 fps (my cap) and only drops when I'm in a HUGELY populated area, down to around 20-50 FPS. Now I'll drop from 200, to around 60 when I'm walking around a zone with no one near me apart from mobs.
    Sounds like it could be a CPU / RAM / Motherboard issue rather than just a Graphics Card problem, as this game tends to use higher RAM / CPU than graphics card memory and stuff at least on mine...

    I can't really give an exact reason why it would do this other than I recommend updating your BIOS / UEFI, and setting it to the proper settings then testing the game as sometimes its not set properly...

    But I can say I ran a I7 6700 K with DDR4 32 GB 3600 RAM, and a 750 TI, as well as the ASUS Maximus VIII motherboard, and I have zero issues with Albion, Crow Fall, or Planet Side 2, before my upgrade though i had all kinds of issues because my older hardware outdated and not properly configured... Also if your using an "ASROCK" motherboard, these cause all kinds of issues and are poorly designed, I would recommend staying with a company like ASUS / ROG.

    And the reason for thinking this is because when I used an Older CPU, but the same graphics card my FPS would drop huge too, and my old CPU was an AMD, it could be something related to certain AMD processors, but then the guy above is using an i5?

    When I ran the graph and checked my GPU usage vs CPU, Albion was using more CPU, and Memory than Video Ram /GPU.