Android Load Screen stuck on 2%

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Android Load Screen stuck on 2%

    I just recently bought a tablet (Nextbook Ares 8 ) for the sole purpose of playing Albion online. I took it right out of its package and cleared the useless apps and then checked to allow download from unkown sources. I downloaded the game through the web browser for android devices and launched the game it starts with the AO logo then the screen goes black it starts loading it sits at 1% for a few seconds then it goes to 2% and stays there for over 24 hours. I plugged my tablet in and let it sit over night it never changed within the next day so i restarted it 10 times and got the same issue. So i deleted it and the download and re-downloaded it 5 times repeating the restarting 10 times then I wiped the entire tablet and re-downloaded again I got the same exact issue. I tried googling solutions someone suggested downloading the windows version instead so i tried all the different OS and none of them could be recognized. Any Idea?

    The post was edited 1 time, last by austyn255 ().