Help please! "The Blackscreen problem"

    • My brother is also having this issue and the above work around of unplugging the monitor before launching game worked for him. He is running a fairly old tv as his monitor and the resolution is also non standard. For Albion he loads the game from the launcher and gets a black screen with a few graphical artifacts and sound, but it just sits permenantly and doesn't load. Using the work around and skipping the intro has helped him to play so thank you. He had a similar issue issue with overwatch where it would crash on loading the game but after communicating with devs they were able to identify the issue being due to his tv/resolution.
    • I am glad to hear it works for other people. I already passed the info to the devs and this time round they seem to (a) not mechanically close my ticket (b) keep the communication channel open. Not sure if they actively work on it (I am more of a "won't believe it till I see it" guy), but I do hope they will fix it this time.

      It is still a beta, so I am fine with showing a lot of patience till they fix it, as long as they don't brainlessly dismiss our reports (we also invest time in troubleshooting and writing them up, they should not ignore that so lightly). :)

    • Unknown3088 wrote:

      I am actually still encountering this issue. Right now its extremely slow loading zones, despite being midnight EST when 1/3 of the player base is online, and ive been getting disconnected after a black screen transitioning zones.
      This is probably similar to the networking-related issue described in Hinji's link, not the same as the one that OP and myself have, which seems to be graphics-related and appears specifically at login, consistently reproducible exactly when launching the game. For your issue you might want to track the link that Hinji posted instead of this one. Not all black screens are equal :P
    • Ok, so I don't know if it will help but I also had the black screen issue and it was due to Peerblock wich is a sort of firewall I use for my peer to peer downloading.
      When I shutted it down, everything came back to normal.

      So maybe this issue is related to firewalls blacklisting Albion Online.

      The post was edited 1 time, last by Merudgark ().

    • Merudgark wrote:

      Ok, so I don't know if it will help but I also had the black screen issue and it was due to Peerblock wich is a sort of firewall I use for my peer to peer downloading.
      When I shutted it down, everything came back to normal.

      So maybe this issue is related to firewalls blacklisting Albion Online.
      Please read my previous post: I believe we have established that this is a graphics issue and not a networking one.

      That said, I really appreciate you trying to help and thank you for that :) I think it might be really helpful to post your findings in threads such as the one below:

      Connection Issues and Black Screens

      These guys also have blackscreens but they are due to networking issues. Although if I remember correctly in the specific thread the problem was appearing midgame so not sure if your solution is relevant to them.

      Edit: the reason I say this is graphics- or coding related: switching from HDMI to VGA without at all messing around with the network setup fixes it. Please read the posts in the thread for more details
    • Merudgark wrote:

      Ok, so I don't know if it will help but I also had the black screen issue and it was due to Peerblock wich is a sort of firewall I use for my peer to peer downloading.
      When I shutted it down, everything came back to normal.

      So maybe this issue is related to firewalls blacklisting Albion Online.
      I have been having the same black screen on and off since I bought the game a few weeks ago. Not consistently at all.
      I have an HDMI connection to my monitor and was starting to think that it might be the problem and then I noticed that my Peerblock was on. I don't usually leave it on and I was considering whether that might be the issue when I read the above post.
      It was the problem after all.
      It is weird to me that I can log into the game to the character select screen just fine but when I try to load the game all I get is the black screen and I can hear sounds like I am loaded.
      Anyway now I know to make sure Peerblock is off.
      I was getting tired of playing this on my phone and connecting it to my monitor so I could actually read stuff.
    • bought the game today and have the same blackscreen problem like all the other ppl here in the thread

      i can see the game when i use the "unplug hdmi cable - start game - replug hdmi cable" - trick :)

      i can only use the game this way in windowed mode and i think some graphic options are deactivated ... like shadows

      is there an official fix for this problem or do i have to get my money back ? (luckily i havent used my gamekey yet :P )

      Win7 - 64bit

      log - pastebin.com/ULb8xhp3
    • Unmok wrote:

      bought the game today and have the same blackscreen problem like all the other ppl here in the thread

      i can see the game when i use the "unplug hdmi cable - start game - replug hdmi cable" - trick :)

      i can only use the game this way in windowed mode and i think some graphic options are deactivated ... like shadows

      is there an official fix for this problem or do i have to get my money back ? (luckily i havent used my gamekey yet :P )

      Win10 - 64bit

      log - pastebin.com/ULb8xhp3
      The bug is still not fixed. It is strange though that you cannot run the game fullscreen after the unplug/replug trick, I can switch back to fullscreen. There are two ways for that:
      - On your Characters login screen, upper left corner there is a button you can press (press it twice for good measure, it glitches the first time)
      - From the graphics settings when finally in game (although I am aware you said the options are grayed out)

      Make sure you try the IN GAME options (and not the launcher ones), since when unplugging/replugging the HDMI cable will always drop you in windowed mode.

      To the Albion devs and reps: a gentle nudge (or shove!!), the bug has remained unfixed for many months, with many players affected, giving them second thoughts on giving the game a chance. Have in mind also that there will be a lot of players which will be affected and not report or post here but just leave quietly due to this problem. That should be enough motivation for you to fix this asap.
    • when i use the "fullscreen button" in the upper left corner ... then my screen goes black again .. sadly

      i couldnt try the ingame graphics option because i can only get to the character creation screen without using my gamekey

      i wanted to wait for a reply befor i use the key to not get "worse" options if i try to get my money back :)
    • Unmok wrote:

      when i use the "fullscreen button" in the upper left corner ... then my screen goes black again .. sadly

      i couldnt try the ingame graphics option because i can only get to the character creation screen without using my gamekey

      i wanted to wait for a reply befor i use the key to not get "worse" options if i try to get my money back :)
      That's a pity. It is also different behaviour from the one most of us have. My bug report is still open, I will post your situation there and see if this helps either SI (as additional info for troubleshooting) or us (by putting some additional pressure since more and more players are affected).

      Cannot really advise you on using the key or not. I risked it because I really wanted to try the game, and after some grief, a few elaborate swearwords that scared my neighbours, and trial and error managed to make it work. Personally I think it was worth it.
    • Frostweaver wrote:

      Try running the game in borderless windowed mode, it does the trick for me, since i got non standard screen
      Good point. Need to note though that after I manage to launch the damn thing, it works flawlessly in both Borderless and Fullscreen mode here.... dunno what to make of it.

      EDIT: out of curiosity, I went to my launcher, set it in fullscreen there and unplugged/launched/replugged. This works here so my client bugs out differently than yours it seems.

      The post was edited 1 time, last by tzervo ().

    • Frostweaver wrote:

      Try running the game in borderless windowed mode, it does the trick for me, since i got non standard screen
      nope ... when i try this and click the ingame fullscreen button ... my game goes into a "zero dimensions" window (pic below)



      i also tried some regedit stuff for another unity game... it seems to affect the game but in no positiv way ^^

      regedit stuff: steamcommunity.com/app/437920/…3284/#c343786195675168129

      edit: if you want to try this .. dont forget to "lock" the keys with user privilege ... otherwise the game changes the options on startup
      edit2: when i google "unity hdmi black screen launch" it seams several unity games have a problem with hdmi ... great -.-

      The post was edited 2 times, last by Unmok ().

    • Unmok wrote:

      ...
      edit2: when i google "unity hdmi black screen launch" it seams several unity games have a problem with hdmi ... great -.-
      Even in this case, we should still be given from SI an official confirmation that the bug is indeed on the engine's side and not in the game's code, with an adequate reference or info about that, in which case I can accept that there is nothing they can do and it is not their fault.
    • Zadig wrote:

      To be clear I do not think its just HDMI. I am running HDMI and do not have this issue. My brother does have this issue and the big difference is his obscure resolution (Which might be in tandem with the fact that it is HDMI).
      Hm, now I am a bit confused. I did suspect the resolution being responsible for the problems initially, especially since switching to VGA might actually change it and throw us off trail by thinking that it is HDMI that is responsible. However I did the following test (I also have a strange resolution 1280 x 720 which is not even supported by the game):

      - switching to another one using display settings (i.e. 1280 x 768) which is supported
      - launching the game

      I was still getting the black screen (I tried it again before posting, just in case I messed up last time, I still get black screen), which made me think it was not a resolution issue. If anyone can draw a conclusion out of this mess I would be very curious to hear it.

      EDIT: The resolution options include my resolution 1280x720 only if I run the game iin fullscreen mode, not in borderless.
    • Several days later ... no help in sight ... opened a ticket ... ask for a refund ... maybe we will se eachother ingame at launch (when bug is hopefully fixed) ^^

      thx for all the help !

      edit: got my refund ... hope the error gets fixed !

      The post was edited 1 time, last by Unmok ().