[Issue solving] Launcher update today

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • I wanted to play today so decided to download, but I keep getting a "Therei s already an Albion Online Launcher running" but there is nothing running.. I am using Linux
    and a ps to see all processes shows nothing is running.
    join our guild [b]Linux Comrades[/b]
    https://forum.albiononline.com/index.php/Thread/59304-Linux-Comrades-PVP-PVE-ALL-CLASSES-ALL-LEVELS-T2-guild-island/#post577279
  • Launcher was working for me untill today (11/05/17), but ever since it updated itself once i launch /opt/albion/Albion-Online binary im getting:

    Source Code

    1. └> [0511/193127:ERROR:browser_main_loop.cc(217)] Running without the SUID sandbox! See https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the sandbox on.
    2. /albion/launcher/QtWebEngineProcess: /albion/launcher/libQt5Core.so.5: version `Qt_5.8' not found (required by /usr/lib/libQt5Positioning.so.5)

    and once i try to run /opt/albion/launcher/Albion-Online:

    Source Code

    1. └> ./Albion-Online
    2. QApplication: invalid style override passed, ignoring it.
    3. WebEngineContext used before QtWebEngine::initialize() or OpenGL context creation failed.
    4. [11471:11471:0100/000000:ERROR:broker_posix.cc(41)] Invalid node channel message
    5. zsh: segmentation fault (core dumped) ./Albion-Online
    I am running ArchLinux.

    Tried both before updating system (with configuration that worked with previous launcher) and after updating everything, but im getting those qt errors still.
  • Midov wrote:

    Launcher was working for me untill today (11/05/17), but ever since it updated itself once i launch /opt/albion/Albion-Online binary im getting:

    Source Code

    1. └> [0511/193127:ERROR:browser_main_loop.cc(217)] Running without the SUID sandbox! See https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the sandbox on.
    2. /albion/launcher/QtWebEngineProcess: /albion/launcher/libQt5Core.so.5: version `Qt_5.8' not found (required by /usr/lib/libQt5Positioning.so.5)
    and once i try to run /opt/albion/launcher/Albion-Online:

    Source Code

    1. └> ./Albion-Online
    2. QApplication: invalid style override passed, ignoring it.
    3. WebEngineContext used before QtWebEngine::initialize() or OpenGL context creation failed.
    4. [11471:11471:0100/000000:ERROR:broker_posix.cc(41)] Invalid node channel message
    5. zsh: segmentation fault (core dumped) ./Albion-Online
    I am running ArchLinux.

    Tried both before updating system (with configuration that worked with previous launcher) and after updating everything, but im getting those qt errors still.
    Iam getting the same error here, running Void Linux with kernel 4.10.14_1.

    Running the binary in /albiononline/:
    [0511/200013:ERROR:browser_main_loop.cc(217)] Running without the SUID sandbox! See chromium.googlesource.com/chro…id_sandbox_development.md for more information on developing with the sandbox on.
    /home/max/albiononline/launcher/QtWebEngineProcess: /home/max/albiononline/launcher/libQt5Core.so.5: version `Qt_5.8' not found (required by /usr/lib/libQt5Positioning.so.5)

    Running launcher in /albiononline/launcher:
    fish: “./albiononline/launcher/Albion-…” terminated by signal SIGSEGV (Address boundary error)

    The above error is also a segmentation fault, my shell just displays it like that.
    In bash the output looks like that:
    Segmentation fault

    greetings, jsus <3
    Linux void 4.10.17_1 x86_64 GNU/Linux
  • Archlinux is what I'm using. Just pasting from my console:

    [######@###### ~]$ sh albiononline/Albion-Online
    [0511/182243:ERROR:browser_main_loop.cc(217)] Running without the SUID sandbox! See chromium.googlesource.com/chro…id_sandbox_development.md for more information on developing with the sandbox on.
    /home/######/albiononline/launcher/QtWebEngineProcess: /home/######/albiononline/launcher/libQt5Core.so.5: version `Qt_5.8' not found (required by /usr/lib/libQt5Positioning.so.5)
  • I was able to get the launcher running by commenting out some lines of the ~/albiononline/Albion-Online shell script, and using the /usr/lib directories instead. Screenshot is of the game updating, as I uninstalled it and deleted the folders that are suggested in the troubleshooting guide on this forum.

    Below is the modified version of the Albion-Online shell script.

    Shell-Script

    1. #!/bin/sh
    2. SCRIPT=$(readlink -f "$0")
    3. SCRIPTPATH=$(dirname "$SCRIPT")
    4. export LD_LIBRARY_PATH=/usr/lib
    5. #export LD_LIBRARY_PATH="$SCRIPTPATH/launcher"
    6. export QT_QPA_PLATFORM_PLUGIN_PATH=/usr/lib/qt/plugins/platforms
    7. #export QT_QPA_PLATFORM_PLUGIN_PATH="$SCRIPTPATH/launcher/plugins/platforms"
    8. export QT_PLUGIN_PATH=/usr/lib/qt/plugins
    9. #export QT_PLUGIN_PATH="$SCRIPTPATH/launcher/plugins/"
    10. "$SCRIPTPATH/launcher/Albion-Online" &

    As you can see on the screenshot, there is something wrong with the browser display.

    After the update. I ran the game from the script and the launcher appeared the same way as the screenshot below, but the game started fine and I am off to feed my foals back at my island :)

    UPDATE:

    The '&' symbol at the end of line 10 is needed if you use the launcher by clicking on the desktop icon. Leave it out if you are running it through the terminal console.

    If you delete all files from

    /albiononline/launcher/

    except for

    Albion-Online, launcher.log, and version.txt

    This will give you a non-distorted browser window at launcher start up (see new screenshot).

    As far as the black screen is concerned, and the error message:

    Player data archive not found at `albiononline/game_x64/Albion-Online_Data/data.unity3d`, using local filesystem

    I have not found an answer yet on how to get past the 1% loading screen when the game is launched.

    I have tried modifying the prefs file at

    .config/unity3d/Sandbox\ Interactive\ GmbH/Albion\ Online\ Client/prefs

    as suggested on other forums, but have not achieved any results.

    Will keep trying...
    Images
    • Screenshot from 2017-06-08 21-40-19.png

      471.24 kB, 859×624, viewed 451 times
    • Screenshot from 2017-05-11 20-00-56.png

      382.27 kB, 865×618, viewed 439 times

    The post was edited 1 time, last by bloodrool: Leaving out '&' symbol is for using launcher through console. Browser display fix. Black screen issue. ().

  • OS: Linux Mint 18 (Ubuntu)
    Kernel: 4.10.2
    QT: 5.8

    [0514/181947:ERROR:browser_main_loop.cc(217)] Running without the SUID sandbox! See chromium.googlesource.com/chro…id_sandbox_development.md for more information on developing with the sandbox on.
    ../Games/albion online/launcher/QtWebEngineProcess: error while loading shared libraries: libQt5Positioning.so.5: cannot open shared object file: No such file or directory

    *EDIT* Solved by using:
    sudo apt-get install qtpositioning5-dev

    The post was edited 1 time, last by Cyb0rg ().