Game client cannot be launched on MBP 2020

    • Game client cannot be launched on MBP 2020

      Hi.. I have a M1 MBP which used to run Albion very smoothly without issue. Last time online was about last Saturday.

      Somehow today on opening the client, it bumped up and down for a few times then could not continue to start the game.
      I have tried deleting the application and re-installing it, but the problem persisted.

      I have attached the crash log for dissection of the problem.

      Please help!
      • Crash log.pdf

        (293.28 kB, downloaded 33 times, last: )
    • Dagother wrote:

      Hey @Collectronz have you used any external keyboard or other input device by any chance?
      Previously yes. But right now I have no external devices attached.

      To add on, previously I have attached to the MBP:
      - an external monitor
      - a bluetooth keyboard
      - a wired mouse
      via a docking device.

      But today on starting I was not using the docking station.

      The post was edited 2 times, last by Collectronz: Supplementation ().

    • An update:

      Despite re-installing the application for about ten times, rewriting permissions, attaching and detaching the external monitor.. Nothing seems to work.

      Tried to install the batch application package, but somehow I don't have admin privileges to use the application. But I am the sole user of the Mac. Will work on that now.

      But overall, very frustrating and it has been taking up quite a lot of time just trying to get it to work. Seems there has been incidents similarly littered around the forum and reddit, but no concrete way to fix any of it yet..

      The post was edited 1 time, last by Collectronz ().

    • @Collectronz could you send me your launcher.log and Player.log files?

      • Player.log: Open Go from the top menu -> then Go to Folder... -> type in ~/Library/Logs/Sandbox Interactive GmbH/Albion Online Client and there you have Player.log - please send it to me via PM.
      • launcher.log: Open Go from the top menu -> then Go to Folder... -> type in ~/Library/Application Support/Sandbox Interactive GmbH/Albion Online Launcher and there you have launcher log - please send it to me via PM