Starting game for linux using steam crashes after clicking play on albion launcher

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Starting game for linux using steam crashes after clicking play on albion launcher

      I wanted to play this game through steam and I use linux, the game does not start after clicking play on the albion launcher and instead dies and stops running, nothing I've tried has been able to make it run not even using steam runtime for linux.
      Can someone help me or is this a bug I just want to play the game.
    • There is no other log files besides the launcher log file, this is what was inside it

      INFO 2021-04-28T16:17:23.433 SSL Support: true
      INFO 2021-04-28T16:17:23.433 SSL lib Compile Time: "OpenSSL 1.0.2k-fips 26 Jan 2017"
      INFO 2021-04-28T16:17:23.433 SSL lib Run Time: "OpenSSL 1.0.2n 7 Dec 2017"
      INFO 2021-04-28T16:17:26.650 "Platform: linux"
      INFO 2021-04-28T16:17:26.650 "Launcher CurrentVersion: launcher-linux-full-"
      INFO 2021-04-28T16:17:26.651 "Game CurrentVersion: albiononline-linux-full-"
      INFO 2021-04-28T16:17:26.651 "Server selected: live"
      INFO 2021-04-28T16:17:28.944 OSNAME: "steamrt"
      INFO 2021-04-28T16:17:29.279 Response: "{ \"status\" : \"online\", \"message\" : \"Server is online.\" }\r"
      INFO 2021-04-28T16:17:30.292 Delete out-dated folder and subfolders "Albion-Online_Data/Plugins/x86_64"
      INFO 2021-04-28T16:17:30.293 Delete out-dated file "Albion-Online_Data/Plugins/"
      INFO 2021-04-28T16:17:30.293 Delete out-dated folder and subfolders "Albion-Online_Data/Plugins/x86_64/"

      it seems to be deleting a bundled library needed for the game cause I have that library, but it just leads to crashing.
      Why would they make it deleted the bundled library I'm so confused?
    • New

      Sorry to reply to a solved thread, but I seem to have the same problem, however creating a folder for game logs at ~/.config/unity3d/Sandbox Interactive GmbH/Albion Online Client/ did not seem to solve my issue, however log file provided by Alex_Yes is the same

      Source Code

      1. INFO 2021-05-04T13:24:44.930 SSL Support: true
      2. INFO 2021-05-04T13:24:44.930 SSL lib Compile Time: "OpenSSL 1.0.2k-fips 26 Jan 2017"
      3. INFO 2021-05-04T13:24:44.930 SSL lib Run Time: "OpenSSL 1.0.2n 7 Dec 2017"
      4. INFO 2021-05-04T13:24:45.075 "Platform: linux"
      5. INFO 2021-05-04T13:24:45.075 "Launcher CurrentVersion: launcher-linux-full-"
      6. INFO 2021-05-04T13:24:45.075 "Game CurrentVersion: albiononline-linux-full-"
      7. INFO 2021-05-04T13:24:45.075 "Server selected: live"
      8. INFO 2021-05-04T13:24:45.652 OSNAME: "endeavouros"
      9. INFO 2021-05-04T13:24:46.028 Delete out-dated file "Albion-Online_Data/Plugins/"
      10. INFO 2021-05-04T13:24:46.029 Delete out-dated file "Albion-Online_Data/Plugins/x86_64/"
      11. INFO 2021-05-04T13:24:46.029 Delete out-dated folder and subfolders "Albion-Online_Data/Plugins/x86_64"
      12. INFO 2021-05-04T13:24:46.030 Response: "{ \"status\" : \"online\", \"message\" : \"Server is online.\" }\r"
      13. INFO 2021-05-04T13:25:00.363 "PLAY Button Pressed"
      Display All
      Here is what is output to the terminal when I try to play the game:

      Display Spoiler

      libpng warning: iCCP: known incorrect sRGB profile
      [0504/] Failed to open file: /memfd:/.glXXXXXX (deleted)
      Error: No such file or directory
      [54664:54664:0504/] Lost UI shared context.
      no life time hint given, falling back to life time hint of 1 day.
      no life time hint given, falling back to life time hint of 1 day.
      no life time hint given, falling back to life time hint of 1 day.
      no life time hint given, falling back to life time hint of 1 day.
      no life time hint given, falling back to life time hint of 1 day.
      Received signal 11 SEGV_MAPERR 000000000024
      #0 0x7fd5ad4be58f <unknown>
      #1 0x7fd5abef085d <unknown>
      #2 0x7fd5ad4bea9e <unknown>
      #3 0x7fd5b2b4e960 <unknown>
      #4 0x7fd5b2c8b6be QString::split()
      #5 0x00000042f434 MainDialog::GetGameCommandLine()
      #6 0x000000433c46 MainDialog::StartGame()
      #7 0x000000439545 MainDialog::on_playButton_clicked()
      #8 0x000000478566 MainDialog::qt_static_metacall()
      #9 0x000000478be5 MainDialog::qt_metacall()
      #10 0x7fd5b2ded504 QMetaObject::activate()
      #11 0x7fd5b47621f2 QAbstractButton::clicked()
      #12 0x7fd5b47623f4 QAbstractButtonPrivate::emitClicked()
      #13 0x7fd5b4763f8e QAbstractButtonPrivate::click()
      #14 0x7fd5b47640e5 QAbstractButton::mouseReleaseEvent()
      #15 0x7fd5b46ad4c8 QWidget::event()
      #16 0x7fd5b4670dac QApplicationPrivate::notify_helper()
      #17 0x7fd5b4678833 QApplication::notify()
      #18 0x7fd5b2dc24e8 QCoreApplication::notifyInternal2()
      #19 0x7fd5b467748f QApplicationPrivate::sendMouseEvent()
      #20 0x7fd5b46c701d QWidgetWindow::handleMouseEvent()
      #21 0x7fd5b46c9913 QWidgetWindow::event()
      #22 0x7fd5b4670dac QApplicationPrivate::notify_helper()
      #23 0x7fd5b4677e57 QApplication::notify()
      #24 0x7fd5b2dc24e8 QCoreApplication::notifyInternal2()
      #25 0x7fd5b3df9e37 QGuiApplicationPrivate::processMouseEvent()
      #26 0x7fd5b3dfbd35 QGuiApplicationPrivate::processWindowSystemEvent()
      #27 0x7fd5b3dd5b7b QWindowSystemInterface::sendWindowSystemEvents()
      #28 0x7fd5a6eceb8b QPAEventDispatcherGlib::processEvents()
      #29 0x7fd5b2dc0e4a QEventLoop::exec()
      #30 0x7fd5b2dc9850 QCoreApplication::exec()
      #31 0x000000416e94 main
      #32 0x7fd5b279cb25 __libc_start_main
      #33 0x0000004185d9 _start
      r8: 0000000000000003 r9: 0000000000000001 r10: fffffffffffffef5 r11: 00007fd5b2c8b650
      r12: 0000000002e010f0 r13: 0000000000000000 r14: 0000000000000001 r15: 00007fffb5b3bc01
      di: 0000000000000020 si: 0000000002e010f0 bp: 0000000000000003 bx: 00007fffb5b3a770
      dx: 0000000000000000 ax: 00007fffb5b3a410 cx: 0000000002e09048 sp: 00007fffb5b3a3e0
      ip: 00007fd5b2c8b6be efl: 0000000000010246 cgf: 002b000000000033 erf: 0000000000000004
      trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000024
      [end of stack trace]
      Calling _exit(1). Core file will not be generated.

      Also, if I run it using proton, so in emulated windows environment it seem to run without any issue, But on native linux it crashes

      The post was edited 2 times, last by GlamirFoshter: Added log ().