Albion Online not launching (EAC Error code 29)

    • Albion Online not launching (EAC Error code 29)

      Hey!

      After today's daily maintenance I have not been able to launch the game at all. I am getting Launch Error (29) from what I believe is EAC, not Albion itself. I have tried repairing and reinstalling through the settings in the launcher and completely uninstalling. I have also gone through and done everything on EACs list on what to do, found here: easy.ac/en-us/support/albion/issues/guide/.

      I also tried to download the game through steam to see if it was possible to launch there, but no difference. Starting the game from the .exe using administrator mode doesn't help either.

      Thanks for any help in advance

      EDIT: Using the launcher found here Known technical issues and workarounds, I was able to get in, but was kicked by EAC after a few seconds.

      EDIT 2: The problem ended up resolving itself. Not sure how.
      Images
      • Screenshot 2021-03-18 133900.png

        70.43 kB, 641×360, viewed 45 times

      The post was edited 2 times, last by Brannstrom ().