Albion Online - How to Fix Black Screen at Login - Server Connection Issues - May 2020 (Not a great solution)

    • Albion Online - How to Fix Black Screen at Login - Server Connection Issues - May 2020 (Not a great solution)

      TL;DR: Install ExitLag or another VPN - Potentially by design and a scam? I'm not sure how else you explain how they ignore the mountain of feedback and complaints. I hate to be cynical here. I have a ticket in with support and will update when I hear back from their team.

      My experience:
      So I'm going to address this only because it doesn't seem that the technical support, developers, or community moderators can manage to do this level of in depth research or response to the community.

      I did 3 and a half hours of troubleshooting tonight because my desktop was getting constantly disconnected from the server and I was getting a black screen.

      To be clear my launcher would load, and then I'd get to the character screen, then I'd be able to log in but the game would be unresponsive - couldn't zone or interact with anything. After about 10 seconds it would go to the login screen. After that the next login attempts would go to a black screen. Sometimes I would get the error someone is already logged into this account.

      I did every single step of troubleshooting you could imagine. I found a ton of complaints about these issues and fixes that ranged from graphical to network. I have done IT support for 10 years so I went through it all.
      -Reinstalling (On Steam)
      -Installing Standalone (for the first time)
      -Install Steam (Aka both new/different directories)
      -Forcing Dx9 launch option from Steam game properties
      -Turning off and on every configuration of graphical settings
      -Making new firewall exceptions
      -Turning off my firewall
      -Adding the game to the geforce experience file directory and optimizing graphical settings
      -Checking the process for any underlying process and whitelisting all of those on the firewall as well
      -Removing trusted devices from my account and then readding them

      I was at the point where I seriously out of ideas. My laptop from the same house could connect over the same router, but my desktop couldn't. I tried everything. The thing I did know was due to the errors it was a server/client connection issue.

      The one last thing I tried.... a VPN. And which VPN? Well ExitLag gets advertised constantly and I just so happened to see ExitLag somewhere on either a suggestion or ad. I decided to give it a try and immediately my issues were solved.

      The only thing I can think here is that there is a server side issues with connecting to specific hosts. I know this might sound a little crazy but what game developer with a game this size absolutely refuses to acknowledge or respond to this much feedback about a specific issue spanning over years, and why is ExitLag advertised every single time in the same video with Albion. Why don't they make servers available for other regions? It is almost like they're funneling users into using ExitLag as a source of income. I really hate to say that but it is definitely a real possibility.

      I'm going to wait for the response on my ticket from support but I've provided them with every single log that's available on my system, and the last possible source of the issue is their servers reception of connection from my client. Seeing as there is no information in my logs at all I'm not sure what else I'm supposed to do or think here.

      So the balls in their court and I'll update you guys with their response.

      PS: It's the ExitLag free trial, I ain't fallin for the funnel trap
    • It's been 16 days since I first submitted my ticket. It took 4 days to get a response asking for logs (which I had mostly already provided) and now it's been 10 days without any update.

      This is a terrible customer service experience. I have been jumping between VPN trials just to play and I'm starting to get to the point where I don't really want to invest any more time into a game for a developer that doesn't care about my experience or solving my problem. I was going to buy premium but I just can't justify it... Why would I give a company money for doing a poor job?

      I am going to give them the benefit of the doubt that their support teams overloaded but if this exceeds a month from ticket open I will not be playing.

      This explains the 3 year old thread with no solved issues. How many people are working support here?
    • I also have a similar problem.
      Very often occurs when going to the Market and after entering the dungeon (Group / solo), also sometimes after leaving the HO.
      When I have a black screen in the dungeon solo, then right after 15 seconds of the black screen I can return to the game, but sometimes, in other cases, I may not be allowed into the game until half an hour.
      Also, this problem arose in others from my guild, but apparently, I most often have it.
    • If you are using an Nvidia Driver like me this may be the permanent solution for anyone who has ever experienced this black screen issue. After you follow these steps your problem will likely be solved. Get the latest Nvidia Driver for your computer here nvidia.com/en-us/geforce/drivers/

      After you install the driver you will need to get to the Albionlauncher.exe in steam folder.

      To get to the folder go to file explorer
      then c:
      then Program Files (x86)
      then click steam
      then click steam apps
      then click common
      then click albion online
      then click launcher,
      finally you will see the Albionlauncher.exe icon.

      Right click the icon and if your setup is like mine you will see run with graphics processer you can choose High Performance Nvidia Processor, or you can choose Integrated Graphics, Initially you will want to choose Integrated Graphics. The game will look shitty but it will bypass the Black Screen. When you get into the game and choose your character and are in the world you must then go to Game Settings up top right corner. There are two options which you will need to change before you can close the application and reopen it using your High Performance Nvidia Processor

      The settings you must change to make the game work around the Black screen are as follows:

      1. Make sure Vsync is NOT checked (you will want to to turn it back on with the High Performance Nvidia Processor but turn it back off if you are closing the game)

      2. Make sure show all effects is OFF (like the first setting you will want to turn it back on when you are in the game with the High Performance Nvidia Processor and turn it off when you leave game or you will get the black screen again)

      When you have turned Vsync button off and show all effects off close the game.

      Go back into the folder following the steps above and right click Albionlauncher.exe again. Now choose High Performance Nvidia Processer and the black screen should be gone. Walla, now you just have to manually turn on vsync and show all effects once you're in for better graphics/ fps and turn them off when you leave game in order to avoid the black screen again. Hope this helps someone else.. Also my comp is Asus Rog Nvidia GeForce GTX 860m, Windows 8.1