[Answered] Adventurer's Challenge Mount Stealth Item Value Change?

    • [Answered] Adventurer's Challenge Mount Stealth Item Value Change?

      EDIT: Answered and updated in patch notes by PrintsKaspian

      Hey, I would like some clarification because I believe this is a bug. Previously, all Adventurer's Challenge mounts had an item value of 0, meaning they were free to repair.

      I assumed this was a benefit of them being these special mounts. Insert my quest to acquire all of them.
      This made the prospect of collecting them very valuable to me for my time in the blue/yellow zones.
      However I just noticed that now they all have very high item values, making them cost on repairs.

      I did not see one single mention of this in recent patches, and it is a VERY recent change as I have been working on this goal for around a month or so.
      Can I get some clarification if this change was intended, and the 0 item value was considered a bug? (and why the change is seemingly undocumented anywhere)
      Or is THIS the bug, and it is an unintended change that'll be fixed? I really hope so, I thought that was an awesome perk of these mounts and am sorely disappointed.

      The post was edited 1 time, last by Azlen: resolved ().

    • I'm 99% sure that the item value being 0 is to avoid quality rolls of this mounts (you cannot reroll the quality of items with 0 value). The most logical explanation i find for this change would be because of percival mount skin addition, since this mounts aren't skins, their value might have been modified (intentionnaly or not).

      PS: some adventurer mounts such as the husky had a positive item value at a point meaning that they could be rerolled, this got changed giving a really high value to quality husky since they become almost unique.
    • Azlen wrote:

      Hey, I would like some clarification because I believe this is a bug. Previously, all Adventurer's Challenge mounts had an item value of 0, meaning they were free to repair.

      I assumed this was a benefit of them being these special mounts. Insert my quest to acquire all of them.
      This made the prospect of collecting them very valuable to me for my time in the blue/yellow zones.
      However I just noticed that now they all have very high item values, making them cost on repairs.

      I did not see one single mention of this in recent patches, and it is a VERY recent change as I have been working on this goal for around a month or so.
      Can I get some clarification if this change was intended, and the 0 item value was considered a bug? (and why the change is seemingly undocumented anywhere)
      Or is THIS the bug, and it is an unintended change that'll be fixed? I really hope so, I thought that was an awesome perk of these mounts and am sorely disappointed.
      Thanks for pointing this out - my apologies for omitting this from the patch notes. It was not intended to be a "stealth" change, simply a bugfix (although an important one for some players) that didn't make it into the patchnotes.

      I've updated the "Fixes" section with the following:
      • Adventurer's Challenge mounts have been assigned a value, meaning repairing them now costs Silver as intended
    • PrintsKaspian wrote:

      Azlen wrote:

      Hey, I would like some clarification because I believe this is a bug. Previously, all Adventurer's Challenge mounts had an item value of 0, meaning they were free to repair.

      I assumed this was a benefit of them being these special mounts. Insert my quest to acquire all of them.
      This made the prospect of collecting them very valuable to me for my time in the blue/yellow zones.
      However I just noticed that now they all have very high item values, making them cost on repairs.

      I did not see one single mention of this in recent patches, and it is a VERY recent change as I have been working on this goal for around a month or so.
      Can I get some clarification if this change was intended, and the 0 item value was considered a bug? (and why the change is seemingly undocumented anywhere)
      Or is THIS the bug, and it is an unintended change that'll be fixed? I really hope so, I thought that was an awesome perk of these mounts and am sorely disappointed.
      Thanks for pointing this out - my apologies for omitting this from the patch notes. It was not intended to be a "stealth" change, simply a bugfix (although an important one for some players) that didn't make it into the patchnotes.
      I've updated the "Fixes" section with the following:
      • Adventurer's Challenge mounts have been assigned a value, meaning repairing them now costs Silver as intended

      Thank you guys for the swift and detailed reply!
      While it's not the answer I wanted, it is the clarification I needed. :)
      It is a little saddening as I worked quite hard after coming back to the game to collect all these mounts heavily due to the 'free' repair nature of them.
      And with them being in the game for so long and assuming it'd been this way since their' inception, I assumed it was a feature. Ahh well, again, I really appreciate the clarification!