Getting disconnected more frequently after today's update.

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Getting disconnected more frequently after today's update.

      Good Day, I'm getting disconnected to all of my characters for every 5 mins, most of the time in less than 5 mins. I usually experience this at 16:00 UTC, but after today's update, I'm getting disconnected even at 9:00-10:00 UTC.

      I'm not sure if it's because of the update or is it because of the increasing number of players here in South East Asia.

      Been playing this game for a year now.
      My first time I can't play the game properly.

      Please fix this.

      Thanks,
      Aymgad
    • Still getting disconnected from the game.

      I have the screenshots of today's disconnections

      We usually have around 200-250 ping in South East Asia.
      But we're experiencing an abnormal ping rate since yesterday.

      Disconnections at:
      14:59 PING - 980
      15:07 PING - 1151
      15:14 PING - 1131
      15:21 PING - 1317


      It's like every 7mins exactly I get disconnected.

      Can anybody help us or explain what's going on?
      Images
      • dc.PNG

        503.89 kB, 996×560, viewed 60 times
      • dc2.PNG

        842.79 kB, 783×573, viewed 59 times
      • dc3.PNG

        930.01 kB, 755×650, viewed 58 times
      • dc4.PNG

        979.86 kB, 753×652, viewed 53 times
    • While reading others post about this issue, I read about Exitlag that can be used until August with Albion (I forgot the exact date).

      I got rid of the disconnection & lags but new problem pop up.

      - Chat Not Working
      - Mail Not Working
      Images
      • problem.JPG

        172.56 kB, 1,089×768, viewed 60 times